<!DOCTYPE html>
<!--[if IE 6]>
<html id="ie6" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 7]>
<html id="ie7" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if IE 8]>
<html id="ie8" lang="en-US" prefix="og: http://ogp.me/ns#">
<![endif]-->
<!--[if !(IE 6) | !(IE 7) | !(IE 8)  ]><!-->
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<!--<![endif]-->
<head>
	<meta charset="UTF-8" />
			
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<link rel="pingback" href="https://www.dallasvoice.com/xmlrpc.php" />

		<!--[if lt IE 9]>
	<script src="https://www.dallasvoice.com/wp-content/themes/Extra/scripts/ext/html5.js" type="text/javascript"></script>
	<![endif]-->

	<script type="text/javascript">
		document.documentElement.className = 'js';
	</script>

	<script>var et_site_url='https://www.dallasvoice.com';var et_post_id='248993';function et_core_page_resource_fallback(a,b){"undefined"===typeof b&&(b=a.sheet.cssRules&&0===a.sheet.cssRules.length);b&&(a.onerror=null,a.onload=null,a.href?a.href=et_site_url+"/?et_core_page_resource="+a.id+et_post_id:a.src&&(a.src=et_site_url+"/?et_core_page_resource="+a.id+et_post_id))}
</script><title>STAGE REVIEW: The born legacy — DTC&#039;s &#039;Frankenstein&#039; - Dallas Voice</title>

<!-- This site is optimized with the Yoast SEO plugin v6.2 - https://yoa.st/1yg?utm_content=6.2 -->
<link rel="canonical" href="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="The born legacy — DTC&#039;s astonishing &#039;Frankenstein&#039;" />
<meta property="og:description" content="The born legacy — DTC&#039;s astonishing &#039;Frankenstein&#039;" />
<meta property="og:url" content="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html" />
<meta property="og:site_name" content="Dallas Voice" />
<meta property="article:section" content="InstanTEA" />
<meta property="article:published_time" content="2018-02-07T23:53:10-06:00" />
<meta property="article:modified_time" content="2018-02-08T00:00:30-06:00" />
<meta property="og:updated_time" content="2018-02-08T00:00:30-06:00" />
<meta property="og:image" content="https://www.dallasvoice.com/wp-content/uploads/2018/02/Kim-Fischer-as-The-Creature-in-Frankenstein-Photo-by-Karen-Almond.jpg" />
<meta property="og:image:secure_url" content="https://www.dallasvoice.com/wp-content/uploads/2018/02/Kim-Fischer-as-The-Creature-in-Frankenstein-Photo-by-Karen-Almond.jpg" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="The born legacy — DTC&#039;s astonishing &#039;Frankenstein&#039;" />
<meta name="twitter:title" content="The born legacy — DTC&#039;s astonishing &#039;Frankenstein&#039;" />
<meta name="twitter:image" content="https://www.dallasvoice.com/wp-content/uploads/2018/02/Kim-Fischer-as-The-Creature-in-Frankenstein-Photo-by-Karen-Almond.jpg" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.dallasvoice.com\/","name":"Dallas Voice","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.dallasvoice.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; Feed" href="https://www.dallasvoice.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; Comments Feed" href="https://www.dallasvoice.com/comments/feed" />
<link rel="alternate" type="application/rss+xml" title="Dallas Voice &raquo; STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217; Comments Feed" href="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.dallasvoice.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.2"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<meta content="Dallas Voice v.2.0.70" name="generator"/><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='extra-style-css'  href='https://www.dallasvoice.com/wp-content/themes/Extra/style.css?ver=2.0.70' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://www.dallasvoice.com/wp-includes/css/dashicons.min.css?ver=4.8.2' type='text/css' media='all' />
<script type='text/javascript' src='https://www.dallasvoice.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.dallasvoice.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<link rel='https://api.w.org/' href='https://www.dallasvoice.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.dallasvoice.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.dallasvoice.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.8.2" />
<link rel='shortlink' href='https://www.dallasvoice.com/?p=248993' />
<link rel="alternate" type="application/json+oembed" href="https://www.dallasvoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.dallasvoice.com%2Fstage-review-born-legacy-dtcs-frankenstein-10248993.html" />
<link rel="alternate" type="text/xml+oembed" href="https://www.dallasvoice.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.dallasvoice.com%2Fstage-review-born-legacy-dtcs-frankenstein-10248993.html&#038;format=xml" />

<!-- This site is using AdRotate v4.9 to display their advertisements - https://ajdg.solutions/products/adrotate-for-wordpress/ -->
<!-- AdRotate CSS -->
<style type="text/css" media="screen">
	.g { margin:0px; padding:0px; overflow:hidden; line-height:1; zoom:1; }
	.g img { height:auto; }
	.g-col { position:relative; float:left; }
	.g-col:first-child { margin-left: 0; }
	.g-col:last-child { margin-right: 0; }
	.g-1 { margin:0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-2 { margin:0px;width:100%; max-width:300px; height:100%; max-height:600px; }
	.g-3 { margin:0px;width:100%; max-width:300px; height:100%; max-height:90px; }
	.g-4 { margin:0px;width:100%; max-width:728px; height:100%; max-height:90px; }
	.g-5 { margin:0px;width:100%; max-width:300px; height:100%; max-height:600px; }
	.g-7 { margin:0px;width:100%; max-width:300px; height:100%; max-height:90px; }
	.g-8 { margin:0px;width:100%; max-width:300px; height:100%; max-height:250px; }
	@media only screen and (max-width: 480px) {
		.g-col, .g-dyn, .g-single { width:100%; margin-left:0; margin-right:0; }
	}
</style>
<!-- /AdRotate CSS -->

<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=1" /><!-- Global Site Tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-60733171-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments)};
  gtag('js', new Date());

  gtag('config', 'UA-60733171-1');
</script>



<script type="text/javascript">
jQuery(document).ready(function($) {
$(" .carousel-item").click(function() {
window.location = $(this).find(" .post-content h3.entry-title a").attr("href"); 

});
});
</script><link rel="stylesheet" id="et-extra-customizer-global-cached-inline-styles" href="https://www.dallasvoice.com/wp-content/cache/et/global/et-extra-customizer-global-15180696311284.min.css" onerror="et_core_page_resource_fallback(this, true)" onload="et_core_page_resource_fallback(this)" /></head>
<body class="post-template-default single single-post postid-248993 single-format-standard et_extra et_fixed_nav et_pb_gutters3 et_primary_nav_dropdown_animation_Default et_secondary_nav_dropdown_animation_Default with_sidebar with_sidebar_right et_includes_sidebar unknown">
	<div id="page-container" class="page-container">
				<!-- Header -->
		<header class="header left-right">
						<!-- #top-header -->
			<div id="top-header" style="">
				<div class="container">

					<!-- Secondary Nav -->
											<div id="et-secondary-nav" class="">
						<ul id="et-secondary-menu" class="nav"><li id="menu-item-241355" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241355"><a href="/advertising">Advertise With Us</a></li>
<li id="menu-item-241356" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-241356"><a href="/marketplace">Marketplace</a>
<ul  class="sub-menu">
	<li id="menu-item-241545" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241545"><a href="https://www.dallasvoice.com/marketplace">View This Week&#8217;s PDF</a></li>
	<li id="menu-item-241546" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241546"><a href="https://www.dallasvoice.com/wp-content/uploads/2017/10/MarketPlace-Rate-Card.pdf">Marketplace Media Kit</a></li>
</ul>
</li>
<li id="menu-item-241357" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-241357"><a href="/outnorthtexas">Out North Texas</a>
<ul  class="sub-menu">
	<li id="menu-item-241547" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241547"><a href="https://www.dallasvoice.com/wp-content/uploads/2018/01/2018-OUT-NT.pdf">Read the Magazine</a></li>
	<li id="menu-item-241548" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241548"><a href="/outnorthtexas/directory">Business Directory</a></li>
	<li id="menu-item-241549" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241549"><a href="https://www.dallasvoice.com/wp-content/uploads/2017/10/2017-OUT-NT-Media-Kit.pdf">OUT Media Kit</a></li>
</ul>
</li>
<li id="menu-item-241358" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241358"><a href="https://www.dallasvoice.com/media-kit">Digital Services</a></li>
<li id="menu-item-241359" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241359"><a href="/contact">Contact Us</a></li>
</ul>						</div>
					
					<!-- #et-info -->
					<div id="et-info">

						
						<!-- .et-extra-social-icons -->
						<ul class="et-extra-social-icons" style="">
																																														<li class="et-extra-social-icon facebook">
									<a href="https://www.facebook.com/DallasVoiceLGBT/" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-facebook"></a>
								</li>
																																															<li class="et-extra-social-icon twitter">
									<a href="https://twitter.com/DallasVoice" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-twitter"></a>
								</li>
																																																																																																																																																																																																										<li class="et-extra-social-icon instagram">
									<a href="https://instagram.com/dallas_voice" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-instagram"></a>
								</li>
																																																																																																																																																																																																																																																																								<li class="et-extra-social-icon youtube">
									<a href="https://www.youtube.com/channel/UCzLKquBnVnmwE8LBYSQTK3w" class="et-extra-icon et-extra-icon-background-hover et-extra-icon-youtube"></a>
								</li>
																																																																																																																																																																																</ul>
						
						<!-- .et-top-search -->
												<div class="et-top-search" style="">
							<form role="search" class="et-search-form" method="get" action="https://www.dallasvoice.com/">
			<input type="search" class="et-search-field" placeholder="Search" value="" name="s" title="Search for:" />
			<button class="et-search-submit"></button>
		</form>						</div>
						
						<!-- cart -->
											</div>
				</div><!-- /.container -->
			</div><!-- /#top-header -->

			
			<!-- Main Header -->
			<div id="main-header-wrapper">
				<div id="main-header" data-fixed-height="80">
					<div class="container">
					<!-- ET Ad -->
						
						
						<!-- Logo -->
						<a class="logo" href="https://www.dallasvoice.com/" data-fixed-height="51">
							<img src="https://www.dallasvoice.com/wp-content/uploads/2017/09/DallasVoice_Website_Logo_cyan.png" alt="Dallas Voice" id="logo" />
						</a>

						
						<!-- ET Navigation -->
						<div id="et-navigation" class="">
							<ul id="et-menu" class="nav"><li id="menu-item-241550" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-241550"><a href="https://www.dallasvoice.com/category/news">News</a></li>
<li id="menu-item-241563" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor menu-item-241563"><a href="https://www.dallasvoice.com/category/lifestyle">Life+Style</a></li>
<li id="menu-item-241352" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241352"><a href="/category/instantea">InstanTEA</a></li>
<li id="menu-item-241353" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241353"><a href="/category/special-editions">Special Sections</a></li>
<li id="menu-item-241691" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-241691"><a href="/plan-your-week">Plan Your Week</a></li>
</ul>							<div id="et-mobile-navigation">
			<span class="show-menu">
				<div class="show-menu-button">
					<span></span>
					<span></span>
					<span></span>
				</div>
				<p>Select Page</p>
			</span>
			<nav>
			</nav>
		</div> <!-- /#et-mobile-navigation -->						</div><!-- /#et-navigation -->
					</div><!-- /.container -->
				</div><!-- /#main-header -->
			</div><!-- /#main-header-wrapper -->

		</header>

				
<div class="sb_ad-section">
	<div class="row">
		<div class="col med-8">
			<div class="g g-4"><div class="g-dyn a-79 c-1"><a href="http://www.aquafestcruises.com/" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/01/Aquafest-728x90.jpg" /></a></div><div class="g-dyn a-82 c-2"><a href="http://www.ticketmaster.com/event/0C005394DC665DC1?camefrom=cfc_LNDALLAS_052718JT_DVWEB" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/01/Live-Nation-Justin-Timberlake.jpg" /></a></div></div>		</div>
		<div class="col med-4">
			<div class="g g-7"><div class="g-dyn a-87 c-1"><a class="gofollow" data-track="ODcsNywxLDYw" href="https://www.dallasvoice.com/wp-content/uploads/2018/02/Valentine-2018.gif" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/02/Valentine-2018-1.gif" /></a></div></div>		</div>
	</div>
</div>

<div id="main-content">
		<div class="container">
		<div id="content-area" class="clearfix">
			<div class="et_pb_extra_column_main">
																<article id="post-248993" class="module single-post-module post-248993 post type-post status-publish format-standard has-post-thumbnail hentry category-featured category-instantea category-lifestyle-instant-tea category-stage et-has-post-format-content et_post_format-et-post-format-standard">
														<div class="post-header">
								<h1 class="entry-title">STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;</h1>
								<div class="post-meta vcard">
									<p><span class="updated">Feb 7, 2018</span></p>
								</div>
							</div>
							
														<div class="post-thumbnail header">
								<img src="https://www.dallasvoice.com/wp-content/uploads/2018/02/Kim-Fischer-as-The-Creature-in-Frankenstein-Photo-by-Karen-Almond.jpg" alt="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" />							</div>
							
														
							<div class="post-wrap">
															<div class="post-content entry-content">
									<p>About a decade-and-a-half ago, as technology was transforming stagecraft into something more cinematic, it became apparent that in addition to lighting and video advancement, theater wanted to Dolby-ize the theatergoing experience. Pulsating white noise could disguise clambering set changes (or mask audience indifference) and shock a play to life like auditory defibrillation. Over the years, adding cacophonous shards of music to non-musical plays has become a trope, often an annoying one.</p>
<p>Yet I confess that the effect has seldom been used more successfully than in the Nick Dear adaptation of<em> Frankenstein</em>, now at the Kalita Humphreys in Uptown, courtesy of Dallas Theater Center. The swell of industrial discordance as the audience wanders to their seats explodes in a flash of thunder that&#8217;s terrifying and alarming. We know we&#8217;re in for something macabre, and boy does the show deliver.</p>
<p>The first 10 minutes or so are essentially dialogue-free, filled with little more than tortured wails from the newly-birthed Creature (Kim Fischer), set to piercing music and horrific images, as this abomination of nature — a golem-like primordial wraith, seemingly comprised of mud and sinew — writhes exquisitely to life. Fischer is more wiry and waifish than the usual hulking monster we expect from the laboratory of Dr. F. (Alex Organ), who barely registers as a character throughout the first half of the play. But while less brutish and physically imposing, the Creature — initially more Lenny from <em>Of Mice and Men</em> than a bolt-necked Karloff — is repulsive, strong and, as it happens, smart. Like Tarzan, he&#8217;s a manifestation of Rousseau&#8217;s noble savage — gutteral, primal, revolting, yet still human. When he meets a kindly blind man (Blake Hackler), he learns language and poetry, and his sharp mind conceives of manmade constructs such as lying, betrayal and morality.</p>
<p>Much late Gothic/early Romantic literature — Mary Shelley&#8217;s included — is talky and moralizing. The Creature is a McGuffin around which bigger issues are debated by the civilized folk. (Shelley&#8217;s book steers clear of ever explaining <em>how</em> Frankenstein accomplished his miracle; Tesla coils and bubbling beakers are entirely a Hollywood addendum.) But Dear&#8217;s construction reverses the typical order: We start off following the Creature in his picaresque, an adventure in discovering his humanity, so that by the time we meet Frankenstein prattling on about whether man can play god, we see the putative hero as an insufferable dick. We know who the real victim is here, and it ain&#8217;t the guy with a girlfriend.</p>
<p>In fact, a subtle undercurrent about Frankenstein is what could be a latent homosexuality — he seems oddly immune to the beauty of his long-suffering fiancee Elizabeth (Jolly Abraham), whom he speak of and to with disparaging contempt; when he finally agrees to marry her, it&#8217;s more ploy than romantic gesture. We come to see Frankenstein not as a wayward genius, nor even grave-digging ghoul or mad scientist, but a frustrated and vindictive monster himself, capable of much worse crimes than the Creature has conceived. He uses the Creature&#8217;s desire to live and enjoy companionship as a weapon against him, not for some strategic advantage but just to be cruel.</p>
<p>Hackler does a standout job as the blind man and in Act 2 as one of Frankenstein&#8217;s minions, but there are two stars who make this show. One, of course, is the astonishing performance by Fischer, who grabs you from the opening seconds and takes us entirely through the lifecycle with him, from a vacant, lobotomized mass of amoral cells (which I call the &#8220;Eric Trump Phase&#8221;) to sophisticated nemesis, beset as much by his need to connect even to his tortures as his pain at living. And the other star is director Joel Ferrell, who tells the story with compelling visuals and a haunted house ethos. At first, this<em> Frankenstein</em> seems scary; but as it delves deeper in the soulless inhumanity of species, it becomes something much worse: prescient.</p>
<p style="text-align: right;">— Arnold Wayne Jones</p>
<p><a href="http://www.dallastheatercenter.org/"><strong>Now through March 4 at the Kalita Humphreys Theater.</strong></a></p>
																	</div>
														</div>
														<div class="post-footer">
								<div class="social-icons ed-social-share-icons">
									<p class="share-title">Share:</p>
									
		
		
		
		
		
		
		
		
		
		<a href="http://www.facebook.com/sharer.php?u=https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html&#038;t=STAGE%20REVIEW%3A%20The%20born%20legacy%20%E2%80%94%20DTC%E2%80%99s%20%E2%80%98Frankenstein%E2%80%99" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Facebook" data-network-name="facebook" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-facebook et-extra-icon-background-hover" ></span>
			</a><a href="http://twitter.com/home?status=STAGE%20REVIEW%3A%20The%20born%20legacy%20%E2%80%94%20DTC%E2%80%99s%20%E2%80%98Frankenstein%E2%80%99%20https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Twitter" data-network-name="twitter" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-twitter et-extra-icon-background-hover" ></span>
			</a><a href="https://plus.google.com/share?url=https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html&#038;t=STAGE%20REVIEW%3A%20The%20born%20legacy%20%E2%80%94%20DTC%E2%80%99s%20%E2%80%98Frankenstein%E2%80%99" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Google +" data-network-name="googleplus" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-googleplus et-extra-icon-background-hover" ></span>
			</a><a href="https://www.tumblr.com/share?v=3&#038;u=https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html&#038;t=STAGE%20REVIEW%3A%20The%20born%20legacy%20%E2%80%94%20DTC%E2%80%99s%20%E2%80%98Frankenstein%E2%80%99" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Tumblr" data-network-name="tumblr" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-tumblr et-extra-icon-background-hover" ></span>
			</a><a href="http://www.pinterest.com/pin/create/button/?url=https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html&#038;description=STAGE%20REVIEW%3A%20The%20born%20legacy%20%E2%80%94%20DTC%E2%80%99s%20%E2%80%98Frankenstein%E2%80%99&#038;media=https://www.dallasvoice.com/wp-content/uploads/2018/02/Kim-Fischer-as-The-Creature-in-Frankenstein-Photo-by-Karen-Almond.jpg" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Pinterest" data-network-name="pinterest" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-pinterest et-extra-icon-background-hover" ></span>
			</a><a href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html&#038;title=STAGE%20REVIEW%3A%20The%20born%20legacy%20%E2%80%94%20DTC%E2%80%99s%20%E2%80%98Frankenstein%E2%80%99" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via LinkedIn" data-network-name="linkedin" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-linkedin et-extra-icon-background-hover" ></span>
			</a><a href="https://bufferapp.com/add?url=https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html&#038;title=STAGE%20REVIEW%3A%20The%20born%20legacy%20%E2%80%94%20DTC%E2%80%99s%20%E2%80%98Frankenstein%E2%80%99" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Buffer" data-network-name="buffer" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-buffer et-extra-icon-background-hover" ></span>
			</a><a href="http://www.stumbleupon.com/badge?url=https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html&#038;title=STAGE%20REVIEW%3A%20The%20born%20legacy%20%E2%80%94%20DTC%E2%80%99s%20%E2%80%98Frankenstein%E2%80%99" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Stumbleupon" data-network-name="stumbleupon" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-stumbleupon et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Email" data-network-name="basic_email" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-basic_email et-extra-icon-background-hover" ></span>
			</a><a href="#" class="social-share-link" title="Share &quot;STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;&quot; via Print" data-network-name="basic_print" data-share-title="STAGE REVIEW: The born legacy — DTC&#8217;s &#8216;Frankenstein&#8217;" data-share-url="https://www.dallasvoice.com/stage-review-born-legacy-dtcs-frankenstein-10248993.html">
				<span class="et-extra-icon et-extra-icon-basic_print et-extra-icon-background-hover" ></span>
			</a>								</div>
																<style type="text/css" id="rating-stars">
									.post-footer .rating-stars #rated-stars img.star-on,
									.post-footer .rating-stars #rating-stars img.star-on {
										background-color: #e8533b;
									}
								</style>
							</div>

																				</article>

						<nav class="post-nav">
							<div class="nav-links clearfix">
								<div class="nav-link nav-link-prev">
									<a href="https://www.dallasvoice.com/local-entertainer-injured-accident-10248990.html" rel="prev"><span class="button">Previous</span><span class="title">Local entertainer injured in accident</span></a>								</div>
								<div class="nav-link nav-link-next">
																	</div>
							</div>
						</nav>
						
										
				<!-- You can start editing here. -->

<section id="comment-wrap">
			<div id="comments" class="nocomments">
			 <!-- If comments are open, but there are no comments. -->

					</div>
					<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a reply</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/stage-review-born-legacy-dtcs-frankenstein-10248993.html#respond" style="display:none;">Cancel reply</a></small></h3>			<form action="https://www.dallasvoice.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">COMMENT</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p>
<p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p>
<p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="text" value="" size="30" maxlength="200" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='248993' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="684c66a023" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="20"/></p>			</form>
			</div><!-- #respond -->
		</section>
			</div><!-- /.et_pb_extra_column.et_pb_extra_column_main -->

			<div class="et_pb_extra_column_sidebar">
	<div id="adrotate_widgets-2" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-5"><div class="g-dyn a-83 c-1"><a class="gofollow" data-track="ODMsNSwxLDYw" href="https://www.rcdallas.org/events/event-calendar/gaybingo" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/01/0217-Gaybingo-FEB-300x600.jpg" /></a></div></div></div> <!-- end .et_pb_widget --><div id="adrotate_widgets-3" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-5"><div class="g-dyn a-83 c-1"><a class="gofollow" data-track="ODMsNSwxLDYw" href="https://www.rcdallas.org/events/event-calendar/gaybingo" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/01/0217-Gaybingo-FEB-300x600.jpg" /></a></div></div></div> <!-- end .et_pb_widget --><div id="adrotate_widgets-4" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-6"><div class="g-single a-86"><a class="gofollow" data-track="ODYsNiwxLDYw" href="http://www.attpac.org/on-sale/2018/luckyplush/?sourceNumber=31912&utm_source=dallas" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/01/LuckyPlush_4_Banners_300x250.jpg" /></a></div></div></div> <!-- end .et_pb_widget --><div id="adrotate_widgets-5" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-6"><div class="g-single a-86"><a class="gofollow" data-track="ODYsNiwxLDYw" href="http://www.attpac.org/on-sale/2018/luckyplush/?sourceNumber=31912&utm_source=dallas" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/01/LuckyPlush_4_Banners_300x250.jpg" /></a></div></div></div> <!-- end .et_pb_widget --><div id="adrotate_widgets-6" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-6"><div class="g-single a-86"><a class="gofollow" data-track="ODYsNiwxLDYw" href="http://www.attpac.org/on-sale/2018/luckyplush/?sourceNumber=31912&utm_source=dallas" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/01/LuckyPlush_4_Banners_300x250.jpg" /></a></div></div></div> <!-- end .et_pb_widget --><div id="adrotate_widgets-7" class="et_pb_widget adrotate_widgets"><h4 class="widgettitle"> </h4><div class="g g-6"><div class="g-single a-86"><a class="gofollow" data-track="ODYsNiwxLDYw" href="http://www.attpac.org/on-sale/2018/luckyplush/?sourceNumber=31912&utm_source=dallas" target="_blank"><img src="https://www.dallasvoice.com/wp-content/uploads/2018/01/LuckyPlush_4_Banners_300x250.jpg" /></a></div></div></div> <!-- end .et_pb_widget --></div>

		</div> <!-- #content-area -->
	</div> <!-- .container -->
	</div> <!-- #main-content -->
	
	<footer id="footer" class="footer_columns_4">
				<div id="footer-bottom">
			<div class="container">

				<!-- Footer Info -->
				<p id="footer-info">© 2017 Dallas Voice.</p>

				<!-- Footer Navigation -->
								<div id="footer-nav">
											<ul class="et-extra-social-icons" style="">
																																								<li class="et-extra-social-icon facebook">
								<a href="https://www.facebook.com/DallasVoiceLGBT/" class="et-extra-icon et-extra-icon-background-none et-extra-icon-facebook"></a>
							</li>
																																									<li class="et-extra-social-icon twitter">
								<a href="https://twitter.com/DallasVoice" class="et-extra-icon et-extra-icon-background-none et-extra-icon-twitter"></a>
							</li>
																																																																																																																																																																																<li class="et-extra-social-icon instagram">
								<a href="https://instagram.com/dallas_voice" class="et-extra-icon et-extra-icon-background-none et-extra-icon-instagram"></a>
							</li>
																																																																																																																																																																																																																																						<li class="et-extra-social-icon youtube">
								<a href="https://www.youtube.com/channel/UCzLKquBnVnmwE8LBYSQTK3w" class="et-extra-icon et-extra-icon-background-none et-extra-icon-youtube"></a>
							</li>
																																																																																																																																																										</ul>
									</div> <!-- /#et-footer-nav -->
				
			</div>
		</div>
	</footer>
	</div> <!-- #page-container -->

	
	<script type='text/javascript'>
/* <![CDATA[ */
var impression_object = {"ajax_url":"https:\/\/www.dallasvoice.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.dallasvoice.com/wp-content/plugins/adrotate/library/jquery.adrotate.dyngroup.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var click_object = {"ajax_url":"https:\/\/www.dallasvoice.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.dallasvoice.com/wp-content/plugins/adrotate/library/jquery.adrotate.clicktracker.js'></script>
<script type='text/javascript' src='https://www.dallasvoice.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var EXTRA = {"images_uri":"https:\/\/www.dallasvoice.com\/wp-content\/themes\/Extra\/images\/","ajaxurl":"https:\/\/www.dallasvoice.com\/wp-admin\/admin-ajax.php","your_rating":"Your Rating:","item_in_cart_count":"%d Item in Cart","items_in_cart_count":"%d Items in Cart","item_count":"%d Item","items_count":"%d Items","rating_nonce":"cd0b119597","timeline_nonce":"051d6ea31c","blog_feed_nonce":"83a200a7ff","error":"There was a problem, please try again.","contact_error_name_required":"Name field cannot be empty.","contact_error_email_required":"Email field cannot be empty.","contact_error_email_invalid":"Please enter a valid email address.","is_ab_testing_active":"","is_cache_plugin_active":"no"};
var et_shortcodes_strings = {"previous":"Previous","next":"Next"};
var et_pb_custom = {"ajaxurl":"https:\/\/www.dallasvoice.com\/wp-admin\/admin-ajax.php","images_uri":"https:\/\/www.dallasvoice.com\/wp-content\/themes\/Extra\/images","builder_images_uri":"https:\/\/www.dallasvoice.com\/wp-content\/themes\/Extra\/includes\/builder\/images","et_frontend_nonce":"76bb34af8b","subscription_failed":"Please, check the fields below to make sure you entered the correct information.","et_ab_log_nonce":"f0a7935302","fill_message":"Please, fill in the following fields:","contact_error_message":"Please, fix the following errors:","invalid":"Invalid email","captcha":"Captcha","prev":"Prev","previous":"Previous","next":"Next","wrong_captcha":"You entered the wrong number in captcha.","is_builder_plugin_used":"","ignore_waypoints":"no","is_divi_theme_used":"","widget_search_selector":".widget_search","is_ab_testing_active":"","page_id":"248993","unique_test_id":"","ab_bounce_rate":"5","is_cache_plugin_active":"no","is_shortcode_tracking":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.dallasvoice.com/wp-content/themes/Extra/scripts/scripts.min.js?ver=2.0.70'></script>
<script type='text/javascript' src='https://www.dallasvoice.com/wp-includes/js/comment-reply.min.js?ver=4.8.2'></script>
<script type='text/javascript' src='https://www.dallasvoice.com/wp-includes/js/wp-embed.min.js?ver=4.8.2'></script>
<script async="async" type='text/javascript' src='https://www.dallasvoice.com/wp-content/plugins/akismet/_inc/form.js?ver=4.0.2'></script>
<!-- AdRotate JS -->
<script type="text/javascript">
jQuery(document).ready(function(){
if(jQuery.fn.gslider) {
	jQuery('.g-1').gslider({ groupid: 1, speed: 60000 });
	jQuery('.g-2').gslider({ groupid: 2, speed: 60000 });
	jQuery('.g-3').gslider({ groupid: 3, speed: 60000 });
	jQuery('.g-4').gslider({ groupid: 4, speed: 60000 });
	jQuery('.g-5').gslider({ groupid: 5, speed: 60000 });
	jQuery('.g-7').gslider({ groupid: 7, speed: 60000 });
	jQuery('.g-8').gslider({ groupid: 8, speed: 60000 });
}
});
</script>
<!-- /AdRotate JS -->

</body>
</html>
